This is becoming so frustrating. On my iPod Touch, I followed the steps to subscribe. The first time I did the steps, I receive the authentication challenge. I think I entered the wrong username, but I never received an error message. No shows appeared for me to download, so I can only suspect that I fat fingered something. I’ve tried using iTunes to subscribe but all it does it shows me the entered URL. Now when I try to subscribe directly on my iPod Touch, I only get a message “Unable to subscribe. Podcast cannot be added because the server or feed cannot be found” I’ve verified my typing of the URL. I’ve gone into my Setting>Podcasts and selected the “Reset Identifier” option. opened the Podcast App and still get the same error message. I’ve been a Komando Subscriber for many, many years and cannot believe how difficult this is! FYI, today, before I started the steps, iTunes updated my iPod to the latest IOS (12.4.3) release and I’m still not able to subscribe. I tried using the Komando App, but it it doesn’t seem to let you download the show for off WiFi listening. I’m very technical, but this is really gotten me stumped. I can’t believe that I’m the only one that found out two weeks ago that they show URL changed, I don’t recall hearing it on the previous shows. Sorry to vent, but I’m at my wits end!