Hello 46797,

I believe you have Miracast or Wifi Direct casting enabled, if you can provide the model number of your TV I may be able to let you know where the setting is to turn it off.

Also if you are connected to the internet over wireless, be sure you are connected to your own wireless network, It might even be worthwhile to change your wireless password to be safe.

If you TV is hardwired to the modem / router, you can disable wireless all together to avoid this issue.