J.C. Hall

Thanks John, I did try setting something else other than Thunderbird or Outlook as the default mail client to see what it would do and it ignored everything and in fact it corrupted Outlook and would crash excel when I was using the email link inside excel which is what I do most of the time.

My solution was to edit the registry: [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail] Change Value (which “Was Not Set”) to Mozilla Thunderbird. Everything works now!