2 replies, 2 voices Last updated by bbgreene 1 month, 2 weeks ago
Viewing 2 reply threads
  • Author
    Replies
    • #51589

      bbgreene
      Participant
      @bbgreene

      I have iMac computer (purchased Dec. 2019) with wireless mouse. I am using Monterey 12.0.1 The mouse has become sluggish and very difficult to use. How can I fix it or do I need to buy a new one? It is not low on its charge.

    • #51593

      TeamKomando:John
      Participant
      @264458

      Hello bbgreene,

      I would start off by making sure nothing is blocking the sensor on the bottom of the mouse, compressed air works great for dusting.

      You could also try resetting Mac’s BlueTooth module by doing the following.

      Press and hold the Option + Shift keys together on your keyboard.
      While pressing the keys, click the Bluetooth icon in the top-right corner of your Mac’s menu bar.
      Then click the Reset the Bluetooth module option. Then follow the onscreen instructions.

      Lastly, you could try the following.

      Reset your Apple mouse
      Press and hold down the Shift + Option key; then on your top menu bar, select the Bluetooth icon.
      Press Debug > Remove All Devices.
      Repeat step 1, this time selecting Reset the Bluetooth Module.
      Now try to pair your mouse again.

      Let us know how it goes.

    • #51595

      bbgreene
      Participant
      @bbgreene

      Thanks so much for the help. I cleaned the sensor as you said and it solved the problem. Greatly appreciate the help.

Viewing 2 reply threads

You must be a Komando Community member to reply to this post. Sign up or log in.