1 reply, 2 voices Last updated by TeamKomando:John 8 months ago
Viewing 1 reply thread
  • Author
    Replies
    • #56716

      Leanne Schmidt
      Participant
      @GmaLea

      I am with a small group of community members who started a nonprofit animal rescue for our county. Two members of our Board have tried unsuccessfully to create a Google for Nonprofits Workspace, which we qualified for. One member used their email address to begin the sign-up process with no issue until he tried to log in using his email address. The process after the email then takes him right to the beginning sign-up again. Another member tried starting it with her email, and I believe she got the error that stated that only the “Super Administrator” has access. The first member stated that the Google help tab is not helpful, and we have been on hold with this process for a few months. Does anyone have any suggestions? I personally may not be able to access this since I wasn’t the one who began the process. If anyone has suggestions to move forward, I’d appreciate your feedback. Or if you know if we can delete the account and start fresh, maybe how to do that?
      Thank you in advance

    • #56756

      TeamKomando:John
      Participant
      @264458

      Hello Leanne,

      Hopefully when you signed up for the nonprofit email you use a .org domain name.
      If you are unable to log in as an administrator into Google Workspace, you will have to go through the domain ownership verification.

      Hopefully, you are still in control of your domain name registrar as this is necessary to recover Google Workspace administrative rights.

      Tap or click here to see how to regain Admin access to your mail host.

Viewing 1 reply thread

You must be a Komando Community member to reply to this post. Sign up or log in.