Hello Terry,

Apple iCloud should be taking care of synchronizing your data between devices. You may only need to check your iCloud settings and check the box next to sync calendars. Removing the checkbox next to calendars and checking the box again a minute later will force a re sync. Additionally make sure all of you devices have the latest updates installed.

Here is what Apple has to say