Hello Karl,

Sorry to hear about your trouble… Can you try going to Phone Settings > Apps > Carrier Services > Storage and clear cache?

Then from the Home screen, tap Messages.
Tap the Menu icon with three dots, then tap Settings > Advanced.
Tap to change the following settings: Group Messaging. Auto-download MMS (on / off) Auto-download MMS when roaming (on / off) Use simple characters (on / off)

A good indicator would be to test and see if you are able to send photos over text to you daughter.

More troubleshooting steps, did you recently come from an iPhone by any chance?

Let us know