I had received a Direct Message from Ken and we were able to get all of his memory recognized by the PC.

“Hey John,
I tried reinstalling the memory after the show today. It took a few tries, but eventually did work. On Crucial’s website I found they have a program that will scan your RAM memory & storage, then make recommendations.
Their scan program told me the EVGA DDR3-2400 Dual Channel (2x8gb) at 1333MHz.
When I did the scan with the Corsair DDR3-1600 Dual Channel (2x4gb) it read the memory at 1600MHz.
If I remember correctly, my motherboard max memory speed is 2100/2133MHz. The motherboard manufacturer is Gigabyte – GA-Z68X-UD3H-B3.
Is there a setting that I can change to increase the 1333MHz to at least 1600MHz?
Force the motherboard to read the EVGA DDR3-2400 at 1600MHz?
Is it the Gigabyte motherboard and EVGA memory don’t get along?
If it’s not a setting issue, then is it an issue with the EVGA DDR3-2400 memory?
Is it bad memory? If so, then it’s too late to do anything about it.
Thank you,

To answer the second question ken, you would not be able to overclock the slower memory to match the faster memory, what is really happening in the background is your faster memory is being downclocked to match the slower memory.

When all the memory is the same speed and depending on the motherboard manufacturer you can sometimes overclock all of the memory. I never overclock due to the issues that it can cause in the future, mainly because overclocking your memory depreciates it lifespan.

Your best bet would be to order 16GB of matching memory for the best performance.