Hello Vherrmann,

Many Mediacom users are facing the same issue, and Mediacom is not providing any answers. Take a look at this forum posting here for more info.

Your best solution would be to ditch Mediacom as an email provider. First configure a new email account Outlook.com or Gmail.com, both are great free solutions. Then set up email forwarding, log into your Mediacom email and click on Preferences. You can manage your email settings, including your email forwarding settings. Configure this with your newly created email address. Another thing you can do configure an auto vacation response message configured to provide people with your newly created email address.

Mediacom is quite vague and does not offer direction on setting up the vacation response, however if you get support on the phone I’m sure they will walk you through both vacation response and forward email.