Hello Jim,

Check this setting I found it by going to messages>settings>notifications>tap the words “incoming messages”>advanced>sound. I suspect you have the sound set to none.

If that does not work, perform a backup of important data and then factory reset by doing the following.

From a Home screen, swipe up to display all apps.
Navigate: Settings. System. Reset options. …
Tap. Erase all data (factory reset).
Tap. Erase all data.
Tap. Erase all data.